Release Note for BV_Ana Ver.1508

Updates from Ver.1312
This version or later is adapted to Windows 64-bit OS only.

1. Additions in Analysis Functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

1-1  New functions for [Wave of ROI] New functions were added in [Analyze]-[Display Window for Wave of ROI/Line].
1-2  New functions for [Multi APD] New functions were added in [Analyze]-[Display Window for APD (multi heart beat)]
1-3  Phase Map Calculated using the Hilbert Transform (new function) [Analyze]-[Display Window for Phase Map using Hilbert transform] menu was added.
1-4  Receiving data from MiCAM05 data acquisition software [File]-[Accept data from MC05Exp] was added in the main menu.
This function allows BV_Ana to receive data from MiCAM05 data acquisition software without saving data. It is possible to send MiCAM05 data from the acquisition software by clicking [to BV_Ana] button.
1-5  Maximum size of 1 data that BV_Ana can handle was expanded up to 2G Byte. "2G Byte" can be selected as maximum size of 1 data from [Utility]-[Memory Control].
1-6  Expansion of canvas size Resolution (pixels) and number of pages can be specified separately. 3 or more pages can be selected.
1-7  TRise Map (new function) [Analyze]-[Display Window for TRise Map] was added in the main menu.
1-8  Slope Map (new function) [Analyze]-[Display Window for Slope Map] was added in the main menu.
1-9  Change ratio of vertical/horizontal size of MiCAM02 data New [HR] button was added on the [Control] tab page.
With this [HR] button, the vertical size of MiCAM02 is expanded 1.67 times so that the ratio of the size in vertical and horizontal can be 1:1.
1-10  Bug fixes and others ・Fixed a problem that BV_Ana aborts if number of frames is not a power of 2 when [Create Filtered-data] button on the [Wave FFT] is clicked.

・Fixed a problem that occurs when data name and folder name include "gsd".

・Fixed a problem that occurs when large size of file is partially loaded on BV_Ana.

・Fixed a problem that title on title bar gets longer when rmg file is saved repeatedly.

・Modified so that version of BV_Ana can be saved in a header file (.gsh).

2. Additions in Data Acquisition Function (Available only for MiCAM02)

2-1  Bug fixes and others ・ Modified to put "B" to name of data, which acquired with camera 2 only (in dual camera mode).

1. Additions in Analysis Functions - Available for MiCAM ULTIMA, MiCAM02, MiCAM01 data

(1-1) New functions for [Wave of ROI]

● Select [Analyze]-[Display Window for Wave of ROI/Line] from the main menu. The window below is opened.
The following functions were newly added.

(1) Up to 64 of ROI can be specified.

(2) When type of ROI is "Polygon" or "Rectangle" or "Oval", user can choose whether area inside ROI is filled or not.
When the [fill color in ROI] checkbox is ON, area inside ROI is filled in colors. When the [fill color in ROI] checkbox is OFF, area inside ROI is not filled.

(3) User can select either differential value or absolute value (light intensity) to be outputted to CSV file when wave data is exported by clicking [Save CSV(average)] button and [Save CSV(each)] button. With [diff] selected, differential value is outputted. With [Intensity] selected, absolute value (light intensity) is outputted.


(1-2) New functions for [Multi APD]

● Select [Analyze]-[Display Window for APD (multi heart beat)] from the main menu. The window below is opened.
The following functions were newly added.

(1) The number of items to be displayed on the top of the histogram was increased. The number next to [histogram for APD] shows the number of action potentials that are processed for analysis.

        When one cycle of each action potential is "RP(msec)",
        BPM : number of action potentials for 1 minute=60000/RP
        Bazett's : = (average value of APD) / √(RP/1000)
        Fridericia's : = (average value of APD) / 3√(RP/1000)    #(1/3 square of (RP/1000))
        Framingham's : = (average value of APD) + 0.154x(1000- RP)

(2) Scale of vertical axis (time axis) for single wave can be specified by manually inputting value (msec).
This value corresponds to "RP" mentioned above.

(3) Gain setting (maximum value and minimum value) for map display is changeable by clicking [▲][▼] buttons next to each map image. The gain setting can be also changed by manually inputting values after [auto Max&Min] checkbox in the [APD Map Option] area is OFF. After values are inputted, push the [ReCalc & Redraw APD Map] button.

(4) [Save this window] button is added. This button saves the entire window as BMP image.

(5) [Export APD values] button is added. This button exports APD values for all action potentials on one selected pixel in a CSV file.

(6) [Manual setting of baseline range] is automatially selected in [select base line setting] when this window is opened.


(1-3) Phase Map Calculated using the Hilbert transform (new function)

● [Analyze]-[Display Window for Phase Map using Hilbert transform] menu was added.
This function is to create phase map that is calculated using the Hilbert transform.

● The Hilbert transform processes data using FFT. Inverse FFT is caclulated by replacing FFT coefficient that corresponds to negative frequencies with "0". Imaginary part of the calculated value is Hilbert value.

(1) Black line shows wave on a selected point before the Hilbert Transform. Red line shows wave of Hilbert value.

(2) This image is obtained by plotting real part Ar to V(t) and imaginary part Ai to V(t+α).

(3) With [Map Create] button, phase map (3) can be drawn.
This map shows phase calculated using arc tangent (atan(Ai/A)).
The phase map is shown in every frame, therefore user can move frames by adjusting the horizontal bar clicking the [Movie] button.

● Please refer to the following paper for more information about the Hilbert transform.

Phase mapping of cardiac fibrillation.
Umapathy K, Nair K, Masse S, Krishnan S, Rogers J, Nash MP, Nanthakumar K.

Circ Arrhythm Electrophysiol.
 2010 Feb;3(1):105-14.





(1-6) Expansion of canvas size

● Select [Canvas]-[Canvas Size] from the main menu. The window below is opened. Number of pages (size of canvas) can be selected from 1 to 10.
Page corresponds to one page that is printed out from [File]-[Print] menu.



(1-7) TRise Map

● [Analyze]-[Display Window for TRise Map] was added in the main menu.
This function is to analyze multiple number of action potentials, similarly to "APD Multi" funciton. With this function, avarage value and standard deviation of rise time of action potential can be obtained and mapped on an image in color.
Rise time of action potential (TRise) can be defined as time until which value of action potential changes from 10% to 90% (100% is maximum value of action potential).
Usage is similar to "APD Multi" funciton.




(1-8) Slope Map

● [Analyze]-[Display Window for Slope Map] was added in the main menu.
Both maximum rising velocity of action potential and TRise time can be obtained and mapped in color.
Rise time of action potential (TRise) can be defined as time until which value of action potential changes from 10% to 90% (100% is maximum value of action potential).

(1) This area shows TRise time and calculation formula.
    TRise time (msec)= (frame number at 90% of maximum value)-(frame number at 10% of maximum value) x sampling time (msec)

(2) TRise map function is added.





(1-9) Change ratio of vertical/horizontal size of MiCAM02 data

● New [HR] button was added on the [Control] tab page.
The upper image shows "a perfect circle" object imaged using MiCAM02. The bottom image shows the data of which vertical scale is changed by clicking [HR] button. The shape of circle changes from an oval to a perfect circle and the ratio of the size in vertical and horizontal can be 1:1.